Home Forums Support 404 Error when trying to connect Android App to Self Hosted

This topic contains 7 replies, has 4 voices, and was last updated by  Titanfail 1 month, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #15220

    cengelhardt
    Participant

    I’m trying to get the mobile app up and running, because to be frank its a bit of a pain to login in a mobile browser and I’m running into a problem with setting up the app.

    Found article (https://www.invoiceninja.com/forums/topic/android-app-setup-issue-with-self-hosted-v4-3-1/) and tried those steps. But when trying to use the API ping function to test if the system can detect the API_Secret I set, I get a 404 error. I also get a 404 error in the app.

    Also when I go into my install of Invoice Ninja I can’t find an API folder.

    Any advice? The previous thread didn’t have any more responses, I am running the current version of the mobile app and a current version of the self-hosted white label Invoice Ninja. I’d also really prefer not to have to reinstall if at all possible.

    Thanks,
    -Chris

    #15221

    Hillel Coren
    Keymaster

    Maybe you need to add /public to the API URL.

    Are you using Android or iPhone? We’ve recently released a beta of our new app available for Android devices.

    https://play.google.com/apps/testing/com.invoiceninja.invoiceninja_flutter

    #15222

    cengelhardt
    Participant

    I’m on android, and that beta app is the one I downloaded.

    #15223

    Hillel Coren
    Keymaster

    If you want to email to [email protected] the link you use to login to the web app and the link you’re using for the mobile app I can check if it looks correct.

    #15224

    cengelhardt
    Participant

    Sent, subject line “Support Post #15220”

    • This reply was modified 5 months ago by  cengelhardt.
    #15226

    Hillel Coren
    Keymaster

    Anything is fine, I handle most support emails.

    #16857

    louk88
    Participant

    It works very well when added /public

    #16861

    Titanfail
    Participant

    If it works when you add /public to the url, you might want to check your server settings and make sure DocumentRoot and whatnot are pointing to /your/invoiceninja/folder/public instead of /your/invoiceninja/folder

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Posted in: