Home Forums Support Android app setup issue with self-hosted v4.3.1

This topic contains 6 replies, has 4 voices, and was last updated by  denisgomes 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #13652

    nico
    Participant

    Hi there,

    I just discovered InvoiceNinja and it’s awesome. I’m playing around at the moment to assess its capabilities and I love it. So far everything went pretty smoothly: web application installation (self-hosted), configuration and testing on computers. However now I’m having an issue with the configuration of the Android app (I haven’t tested with iPhone). I naturally downloaded InvoiceNinja app v 1.15.0 from Play Store on my Samsung S8 Plus. After setting up web app on the server, the URL and the API_SECRET on the mobile app as per the documentation http://docs.invoiceninja.com/en/latest/mobile_apps.html, I hit the confirm button and got the error message “Something went wrong. Undefined error occured.”

    Any help would be much appreciated.

    Thanks
    Nico

    #13653

    DavidBomba
    Keymaster

    The most common reasons we see failures:

    1. In correct URL: Test your URL YOUR_URL/api/v1/ping?api_secret=API_SECRET

    Should return success

    2. Invalid / self signed SSL.

    #17556

    mayol
    Participant

    I am having the same issue. I install invoice ninja on my website, download the mobile app to login and it request that I enter the API_SECRET. I went through the document http://docs.invoiceninja.com/en/latest/mobile_apps.html and i can find the ” .env file”.

    Pleased I need the file name where the (.env file) so i can work on it. steps, name and location of the file to access (.env file) will be appreciated

    #17558

    nico
    Participant

    So I have upgraded to 4.5.1 and have tested with the URL: https://YOUR_URL/api/v1/ping?api_secret=API_SECRET

    and I get:
    {
    “error”: {
    “message”: “Invalid token”
    }
    }

    I have changed the API SECRET value but I still get the same result.

    The SSL certificate is handled by “Let’s Encrypt”.

    Any ideas?

    Cheers
    Nico

    • This reply was modified 1 month ago by  nico.
    #17559

    nico
    Participant

    Hey @mayol,

    “First, you’ll need to add an additional field to your .env file which is located in the root directory of your self-hosted Invoice Ninja installation.”

    Check in the root of the folder of your app and make sure you can see hidden files.

    Cheers
    Nico

    #17848

    denisgomes
    Participant

    I am too having problems with the Android app with v4.5.4. I have added the API SECRET key to the env file and the API ping url returns “success” but the app won’t connect.

    Looks like it can create a token, though.

    #17849

    denisgomes
    Participant

    I also have problems with Zapier. Never managed to fix it, I’ve given up after trying for many hours and creating one thread here.

    I really cannot understand what the heck is going on. Every test so far seems to indicate it is working okay.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Posted in: