Home Forums Support Autocomplete country field

This topic contains 7 replies, has 2 voices, and was last updated by  Hillel Coren 5 days, 15 hours ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #17054

    Laurens
    Participant

    Hi

    Could you add autocomplete=”off” to the country field of customers and suppliers?
    It’s hard to select a country from the Invoice Ninja List if Chrome popups all kind of suggestions above it?

    I also see a text above the postal code “City will be filled in automatically”, but it’s not, how can I populate this DB for my country? I’m talking about self-host btw.

    Is it an idea to add a default category to a supplier? That way that expense categorie is auto selected when adding an expensive from that supplier?

    Thanks
    Laurens

    #17055

    Hillel Coren
    Keymaster

    – Sure, happy to add it.

    – You need to have a Google API key: https://invoice-ninja.readthedocs.io/en/latest/configure.html#google-map

    – Feel free to add an issue on GitHub.

    #17216

    Laurens
    Participant

    I do have the Google API key set as I can see the Google Maps on customers, but no auto complete?

    #17221

    Hillel Coren
    Keymaster

    Not sure… is your country set on Settings > Company Details?

    #19274

    Laurens
    Participant

    Yes it is, it seems to work for addresses in Germany, but not in Belgium or The Netherlands.

    #19277

    Hillel Coren
    Keymaster

    If the company country is set to Germany you’d need to set the client country before looking up the postal code.

    #19278

    Laurens
    Participant

    It’s set to Belgium. I tried filling in the country first, but it’ still not completing Belgium addresses.
    For example 9000 would need to give Gent/Ghent in Belgium.

    #19349

    Hillel Coren
    Keymaster

    I think this feature needs to be improved. We map the results from Google to address fields but it looks like the format of the data is different for different countries. We’ll try to improve this when migrating the feature to v2.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Posted in: