Home Forums Support Client login error

This topic contains 14 replies, has 4 voices, and was last updated by  Toesieo 6 days, 21 hours ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #23559

    Toesieo
    Participant

    Good day,

    When i try to login as a client by visiting “invoice_ninja_install/client/login” I get the error “Whoops, looks like something went wrong.” I’m not sure when it started from since I don’t normally have client logins. I can provide debug info if requested. This is a self hosted white labeled installation.

    #23561

    Titanfail
    Participant

    Any time you get a “Whoops, looks like something went wrong” page, there should be a corresponding error in /ninja/storage/logs/laravel-error.log

    #23566

    Hillel Coren
    Keymaster

    Thanks Titanfail!

    A useful tip is if you’re logged-in you can use /error (or /public/error) to check the logs in the browser.

    #23605

    Toesieo
    Participant

    Hi guys. Thanks for taking time to help. Let me apologize for the late response. I spent the last 2 days trying to figure out why my ‘laravel-error.log’ is missing, and recreating the “Whoops, looks like something went wrong.” error to get it recorded to the log file I created manually. I get the error but nothing is recorder to the log file. I am lost as to what’s happening. Invoice Ninja works normally from the admin end. Also if I try to visit /error (or /public/error) I get “Sorry, the page you are looking for could not be found.”

    #23615

    Hillel Coren
    Keymaster

    Sorry, it /errors or /public/errors (‘s’ at the end)

    #23617

    Toesieo
    Participant

    Thanks Hillel. I get ‘There are no errors’ when i visit ‘/errors’. ‘/public/errors’ doesn’t work for me in this case.

    #23618

    Randy
    Participant

    @hillel: your and @titanfail‘s replies are the reason I hang out in this forum, I get so much information from reading your comments that I keep it all bundled for later.

    Is there some documentation about all your comments or is this Laravel related?

    #23635

    Toesieo
    Participant

    Any idea on what is causing my client portal to not work? Please note that I have no problem viewing client portals when I click ‘View in Portal’ on the admin side.

    #23637

    Hillel Coren
    Keymaster

    Sorry I’m not sure, if you see “Whoops..” there should be more details in the error log.

    One option is to enable APP_DEBUG in the .env file however we don’t advise enabling this setting in production as it can leak secure credentials.

    #23638

    Randy
    Participant

    Can you check the website url? Is there maybe a double ‘/’ in it?

    #23639

    Toesieo
    Participant

    Thanks Hillel, I enabled debugging to see what I get when I login to /client/login I get “Account not resolved in client login /REDACTED/public_html/inv/vendor/laravel/framework/src/Illuminate/Foundation/Application.php#940” as an Exception and
    “errors::500 (vendor/laravel/framework/src/Illuminate/Foundation/Exceptions/views/500.blade.php)
    errors::layout (vendor/laravel/framework/src/Illuminate/Foundation/Exceptions/views/layout.blade.php)” as Views

    Thanks Randy, there are no double ‘/’ in the URL.

    #23640

    Hillel Coren
    Keymaster

    If you have multiple companies you need to use the URL from Settings > Client Portal which includes the account_key query param

    #23641

    Toesieo
    Participant

    Yesss! That was the issues. I added a new company a few weeks ago but I didn’t think that the Client Portal URL would have to differentiate between the 2 somehow. The ‘account_key query param’ in the URL does that. Hillel, you helped me once again. Thank you for your outstanding dedication. One last question, how is version 2.0 coming?

    #23642

    Hillel Coren
    Keymaster

    Glad to hear it 🙂

    v2 is coming along great, we hope to have an alpha release in one or two months.

    #23643

    Toesieo
    Participant

    Very good, I’m looking forward to it.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Posted in: