Home Forums Support Client portal password reset link is broken

This topic contains 3 replies, has 2 voices, and was last updated by  Anonymous 2 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21543

    Anonymous

    Hello I am self-hosting an instance of invoiceninja. Everything is working swell except for the client password reset. I can create a client, give said client a password, then i can go to the client/login and login to the client side portal without any problem. When i navigate to the client/login page and click the “recover your password”, i get the reset email but when i click on the “reset” button i get a “sorry the page you are looking for could not be found. I am looking at my apache logs and i don’t see any entries in the log file that would shed any light on the situation. Any help or suggestions would be greatly appreciated. Thank you.

    Brian

    #21544

    Hillel Coren
    Keymaster

    I’d suggest checking that APP_URL is correct in the .env file.

    Also, try using incognito mode when clicking the portal link.

    #21545

    Anonymous

    Sorry I should have mentioned in my orginal post that I did check my .env file and the APP_URL is correct. I’ve tried using incognito mode and non incognito mode when clicking the link and still nothing works.

    Also, I can’t reset the regular user (???) passwords either. I’m pretty sure I screwed up my personal user password when I set it up a couple of days ago and had to reset it. it worked then, but I’m not a 100% positive I clicked the reset link either.

    #21547

    Anonymous

    Here is the debug info i get when i turn debug on:

    (1/1) NotFoundHttpException
    in RouteCollection.php (line 179)
    at RouteCollection->match(object(Request))
    in Router.php (line 546)
    at Router->findRoute(object(Request))
    in Router.php (line 525)
    at Router->dispatchToRoute(object(Request))
    in Router.php (line 511)
    at Router->dispatch(object(Request))
    in Kernel.php (line 176)
    at Kernel->Illuminate\Foundation\Http\{closure}(object(Request))
    in Pipeline.php (line 30)
    at Pipeline->Illuminate\Routing\{closure}(object(Request))
    in Debugbar.php (line 51)
    at Debugbar->handle(object(Request), object(Closure))
    in Pipeline.php (line 148)
    at Pipeline->Illuminate\Pipeline\{closure}(object(Request))
    in Pipeline.php (line 53)
    at Pipeline->Illuminate\Routing\{closure}(object(Request))
    in CheckForMaintenanceMode.php (line 46)
    at CheckForMaintenanceMode->handle(object(Request), object(Closure))
    in Pipeline.php (line 148)
    at Pipeline->Illuminate\Pipeline\{closure}(object(Request))
    in Pipeline.php (line 53)
    at Pipeline->Illuminate\Routing\{closure}(object(Request))
    in HandlePreflight.php (line 46)
    at HandlePreflight->handle(object(Request), object(Closure))
    in Pipeline.php (line 148)
    at Pipeline->Illuminate\Pipeline\{closure}(object(Request))
    in Pipeline.php (line 53)
    at Pipeline->Illuminate\Routing\{closure}(object(Request))
    in Pipeline.php (line 102)
    at Pipeline->then(object(Closure))
    in Kernel.php (line 151)
    at Kernel->sendRequestThroughRouter(object(Request))
    in Kernel.php (line 116)
    at Kernel->handle(object(Request))
    in index.php (line 51)

    /var/www/html/vendor/laravel/framework/src/Illuminate/Routing/RouteCollection.php#179

    return $this->getRouteForMethods($request, $others);
    }
    throw new NotFoundHTTPException;
    }

    Symfony\Component\HttpKernel\Exception\NotFoundHttpException

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Posted in: