Home Forums Support Customers Unable to Pay Invoices

This topic contains 15 replies, has 2 voices, and was last updated by  Hillel Coren 3 months ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #18385

    WhatNoWebsite
    Participant

    Hi Hillel

    Since the billing system seems incapable of profucing PDFs that can be read I disabled this feature
    (https://www.invoiceninja.com/forums/topic/invoices-not-being-attached-to-mails/)

    I have also disabled the password feature mso users can simply open the invoice in the portal and pay but now when they click “Pay Now” the system just hangs.

    Two clients have had the same issue today alone, here’s a message from one of them:

    I’ve tried several times over the last few days to make payment of this invoice using the pay now option on the portal. It keeps hanging once I press the pay button and won’t progress further. I have now given up and paid by bank transfer.

    Thoughts on how I might resolve this as it’d be quite nice to actually allow people to pay since they cannot even receive an invoice attached now.

    #18387

    Hillel Coren
    Keymaster

    Have you checked the logs for any errors?

    #18389

    WhatNoWebsite
    Participant

    Thanks for the quick response Hillel

    Please point me to the file(s) and I’ll take a quick look.

    #18390

    Hillel Coren
    Keymaster

    storage/logs/laravel-error.log
    storage/logs/laravel-info.log

    #18392

    WhatNoWebsite
    Participant

    I don’t see anything relating to the bill payment UI, just this:
    [2019-01-17 06:57:05] production.ERROR: PhantomJS - Failed to load https://XXXXXX.whatnowebsite.co.uk/view/XXXXXXphantomjs=true&phantomjs_secret=XXXXXX: File does not exist or is not executable: /public_html/phantomjs-2.1.1-linux-x86_64/bin/phantomjs {"context":"PHP","user_id":1,"account_id":"1","user_name":"XXXXXX","method":"PUT","user_agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0","locale":"en","ip":"XXXXXX","count":1,"is_console":"no","is_api":"no","db_server":"mysql","url":"invoices/1738"} []

    #18393

    Hillel Coren
    Keymaster

    I’d suggest using test mode and checking for any errors in the browser console when trying to pay an invoice.

    #18394

    WhatNoWebsite
    Participant

    OK, I can give that a try. How do I put the site into test mode please…?

    #18395

    Hillel Coren
    Keymaster

    You can enable test mode by clicking the gateway on Settings > Online Payments

    #18396

    WhatNoWebsite
    Participant

    Thanks Hillel

    I went to the page in question and could not see this option so I then opened the Stripe gateway and again no option was available to put it into test mode.

    #18397

    Hillel Coren
    Keymaster

    To enable test mode with Stripe you need to use Stripe’s test API keys

    #18398

    WhatNoWebsite
    Participant

    I tried this just a moment ago and the page STILL hangs when I click the “Pay now” button:
    http://prntscr.com/m8bk23

    #18399

    WhatNoWebsite
    Participant

    I then switched to the live credentials for Stripe and the same happened.

    When I opened up the console I saw this:
    http://prntscr.com/m8bl96

    #18400

    Hillel Coren
    Keymaster

    Thanks for the screenshot!

    You should be able to fix it by enabling the billing address in the payment gateway settings.

    We’re working on a release later today which will include a fix.

    #18401

    WhatNoWebsite
    Participant

    Thanks Hillel

    Do you mean I should enable this option…?
    http://prntscr.com/m8bnb5

    #18402

    WhatNoWebsite
    Participant

    I think you did.

    I changed that option and it seems to work with a test card so will wait and see what happens with the next invoice payments.

    #18403

    Hillel Coren
    Keymaster

    That is correct

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

Posted in: