Home Forums Support Default tax in invoices not preselected

This topic contains 21 replies, has 3 voices, and was last updated by  Magic 1 month ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #8991

    ysintos
    Participant

    Hello,

    I set the default tax in settings but when i create an invoice that defeult tax is not preselected.
    It is not something hard to select it, but the problem is that most of the times i forget to set it and the tax on the invoice is set to null-none-zero.
    Anyone has the same issue ?

    #8999

    Hillel Coren
    Keymaster

    It seems to be working in my tests, the default tax selected on /settings/tax_rates is selected when creating a new invoice.

    Are you using invoice taxes or line item taxes?

    #9000

    ysintos
    Participant

    I am using invoice taxes.
    Unfortunatelly it is not working on me 🙁

    #9001

    Hillel Coren
    Keymaster

    Can you check you’re using an exclusive tax rate, we don’t support using inclusive rates as a default.

    #9002

    ysintos
    Participant

    What is an exclusive tax rate and what is the inclusive one ?

    #9003

    Hillel Coren
    Keymaster

    You can see an explanation on /tax_rates/create

    #9004

    ysintos
    Participant

    I use exclusive rate.

    #9006

    Hillel Coren
    Keymaster

    Do you see the same problem on invoiceninja.com

    #9007

    Hillel Coren
    Keymaster

    I’m assuming you’re referring to the self-host web app.

    #9008

    ysintos
    Participant

    Exactly.
    I can’t understand why this is happening.
    Do you want meto give you the credentials to check it ?

    #9009

    Hillel Coren
    Keymaster

    Can you post or email us a screenshot of your settings on /settings/tax_rates

    #9010

    ysintos
    Participant
    #9011

    Hillel Coren
    Keymaster

    Thanks, maybe it’s a localization issue?

    #9012

    ysintos
    Participant

    I don’t know how to check it.

    #9014

    Hillel Coren
    Keymaster

    Does the problem occur if the tax name is in English?
    Also, do you see the problem on invoiceninja.com?

    #9015

    ysintos
    Participant

    Hello,

    If i change the name of the tax to English, the problem is gone.
    So i guess it has to do something with the language.

    #9016

    Hillel Coren
    Keymaster

    Great, that’s helpful to know. Can you post an example tax rate name you’re using.

    #9017

    ysintos
    Participant

    Κανονικός ΦΠΑ

    24%

    #9018

    Hillel Coren
    Keymaster
    #9019

    ysintos
    Participant

    It worked.

    Thank you so much.

    #9020

    Hillel Coren
    Keymaster

    Great to hear, thanks for your help debugging!

    #21884

    Magic
    Participant

    I am currently trying to solve the exact same problem. This thread seems to be rather old and I thought that it was merged already, was not it?

    I have the default tax rate set in the admin interface (exclusive) and I use an option to add tax for each item (because in such case the whole invoice rate counts tax twice).

    The problem is that I need to select tax for each item manually and its not automatically preselected.

    My default language is not English (Czech).

    The problem is present in InvoiceNinja.com demo.

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.

Posted in: