Home Forums Support Does the iPhone app require SSL

This topic contains 3 replies, has 2 voices, and was last updated by  Hillel Coren 5 months, 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #20932

    MeLKoR
    Participant

    I have been using self hosted webapp for about 3 months and am loving it.

    I only use the webapp for invoicing and marking them off as paid, there is very little personal data and no payments accepted via the webapp so i did not see the point of getting an SSL cert. However i want to start using the API and iPhone app but i keep getting 404 errors.

    i have followed the instructions and add the API_SECRET=<password> to the .env file, and this has made no difference.

    When i run “<MY_URL>/api/v1/ping?api_secret=<password>” i get a 404 error.

    I am not that good with HTTPS VS HTTP, i am also not that good with APIs but when i look in the root i cannot see an API folder, should i see one there?

    any help would be awesome.

    Thanks

    Tony

    #20935

    Hillel Coren
    Keymaster

    Maybe you need to add /public to the URL, it should match the URL you use to access the web app.

    #20936

    MeLKoR
    Participant

    Thank you, that was the issue.

    i was going on the therory that

    “The first is the Base URL of your self-hosted installation, ie http://ninja.yourapp.com

    meant http://ninja.yourapp.com and not http://ninja.yourapp.com/public

    Maybe that is something the doco team can update on the user manual?

    Thanks again Hillel Coren!!!

    #20937

    Hillel Coren
    Keymaster

    Awesome, glad to hear it!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Posted in: