Home Forums Support Enable SSL

This topic contains 5 replies, has 2 voices, and was last updated by  Hillel Coren 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #19446

    julianengel13
    Participant

    Good morning! I’m really loving Invoice Ninja so far, it’s been amazing! I’m running it in a docker container using a reverse proxy, and I’ve managed to enable SSL on my subdomain invoices.orgname.com using let’s encrypt.

    Now, the problem is if I try to access teh site over SSL, all the CSS and JS are loaded from the http version of the site, causing there to be a ton of errors… (Unless I load unsafe scripts).

    I’m not sure how to let the install know to use the new SSL version of the site. I changed the app install URL in the settings, however that did not do much.

    Thanks in advance!

    #19447

    Hillel Coren
    Keymaster

    Thanks, that’s great to hear 🙂

    Maybe some of the info here will help:

    https://github.com/invoiceninja/invoiceninja/issues/1393

    #19448

    julianengel13
    Participant

    Thanks for the swift reply! Unfortunately… that didn’t work :/ Still loading from the old link it looks like :/ the http one

    #19449

    Hillel Coren
    Keymaster
    #19450

    julianengel13
    Participant

    YES! Thank you!

    Adding this to the nginx.conf fixed it!

    fastcgi_param HTTPS 1;

    #19451

    Hillel Coren
    Keymaster

    Awesome, glad to hear it’s working!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Posted in: