Home Forums Support Error 403 after updating

This topic contains 9 replies, has 2 voices, and was last updated by  alnxp 1 month, 2 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #24324

    alnxp
    Participant

    I just tried to update it as it is described here and right after it when I try to access the /ninja/ in my website, I get the error 403. I already tried to upload the old backup .htaccess and also re upload the files. Didn’t work. Where’s the log? How can I fix it?

    #24325

    Hillel Coren
    Keymaster

    Which version did you update to?

    #24326

    alnxp
    Participant

    Latest. I got and followed it here: https://invoice-ninja.readthedocs.io/en/latest/

    #24327

    Hillel Coren
    Keymaster

    So v4.5.18?

    If you’re seeing a 403 I suggest checking the web server error log, the app logs are in storage/logs

    #24328

    alnxp
    Participant

    Alright, I says this:

    [Tue Apr 07 11:38:04.291508 2020] [:error] [pid 988939:tid 140329633920768] [client 179.209.61.221:50239] SoftException in Application.cpp:657: Directory “/home1/allan680/public_html/theninja” is writeable by group

    #24329

    alnxp
    Participant

    Is it only a thing of permissions? I tried it too it keep failing. Maybe there’s the right file to config? I tried the htaccess only.

    • This reply was modified 1 month, 2 weeks ago by  alnxp.
    #24330

    Hillel Coren
    Keymaster

    Maybe try to making the folder not writeable by group?

    #24332

    alnxp
    Participant

    I set .htaccess and the main folder Ninja to 7 4 4. That’s readable and executable isn’t it? What am I overlooking at?

    [Tue Apr 07 12:01:06.144958 2020] [core:crit] [pid 20018:tid 140329650706176] (13)Permission denied: [client 179.209.61.221:55749] AH00529: /home1/allan680/public_html/theninja/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that ‘/home1/allan680/public_html/theninja/’ is executable

    #24333

    alnxp
    Participant

    I tried several combinations and got it right. But now it’s returning the line above. Any idea?

    [Tue Apr 07 12:29:28.311005 2020] [autoindex:error] [pid 74127:tid 140329701062400] [client 179.209.61.221:55854] AH01276: Cannot serve directory /home1/allan680/public_html/theninja/: No matching DirectoryIndex (index.html.var,index.htm,index.html,index.shtml,index.xhtml,index.wml,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.js,index.jp,index.php4,index.php3,index.php,index.phtml,default.htm,default.html,home.htm,index.php5,Default.html,Default.htm,home.html) found, and server-generated directory index forbidden by Options directive

    #24338

    alnxp
    Participant

    I got it. I had to add several different permissions and several files. Thank you.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Posted in: