Home Forums Support Error 403 Windows 10 and xampp

This topic contains 4 replies, has 2 voices, and was last updated by  fartilesj 1 month, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #24454

    fartilesj
    Participant

    Hi, I am using self-hosting, well I am trying to install invoice ninja on windows 10 with xampp and php 7.3, but when accessing localhost/ninja/public to start the installation it gives me error 403. The same thing happens by accessing to localhost/ninja. what am I doing wrong? Thanks a lot

    #24455

    Hillel Coren
    Keymaster

    Are there any errors in the web server error logs?

    #24456

    fartilesj
    Participant

    Apache error logs:

    [Sat Apr 18 23:19:04.280901 2020] [ssl:warn] [pid 11840:tid 588] AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Sat Apr 18 23:19:04.421517 2020] [core:warn] [pid 11840:tid 588] AH00098: pid file C:/xamppPortable-x64-php7.3-Pruebas/apache/logs/httpd.pid overwritten — Unclean shutdown of previous Apache run?
    [Sat Apr 18 23:19:04.437142 2020] [ssl:warn] [pid 11840:tid 588] AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    PHP Warning: Module ‘mysqli’ already loaded in Unknown on line 0
    PHP Warning: Module ‘openssl’ already loaded in Unknown on line 0
    [Sat Apr 18 23:19:05.187089 2020] [mpm_winnt:notice] [pid 11840:tid 588] AH00455: Apache/2.4.41 (Win64) OpenSSL/1.1.1c mod_fcgid/2.3.10-dev PHP/7.3.14 configured — resuming normal operations
    [Sat Apr 18 23:19:05.187089 2020] [mpm_winnt:notice] [pid 11840:tid 588] AH00456: Apache Lounge VC15 Server built: Aug 11 2019 12:20:04
    [Sat Apr 18 23:19:05.187089 2020] [core:notice] [pid 11840:tid 588] AH00094: Command line: ‘c:\\xamppportable-x64-php7.3-pruebas\\apache\\bin\\httpd.exe -d C:/xamppPortable-x64-php7.3-Pruebas/apache’
    [Sat Apr 18 23:19:05.202713 2020] [mpm_winnt:notice] [pid 11840:tid 588] AH00418: Parent: Created child process 13452
    [Sat Apr 18 23:19:06.640131 2020] [ssl:warn] [pid 13452:tid 592] AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Sat Apr 18 23:19:06.749481 2020] [ssl:warn] [pid 13452:tid 592] AH01909: http://www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    PHP Warning: Module ‘mysqli’ already loaded in Unknown on line 0
    PHP Warning: Module ‘openssl’ already loaded in Unknown on line 0
    [Sat Apr 18 23:19:06.999481 2020] [mpm_winnt:notice] [pid 13452:tid 592] AH00354: Child: Starting 150 worker threads.
    [Sat Apr 18 23:19:43.385842 2020] [rewrite:error] [pid 13452:tid 1968] [client ::1:51559] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : C:/xamppPortable-x64-php7.3-Pruebas/htdocs/ninja-v4.5.18/
    [Sat Apr 18 23:20:02.931361 2020] [rewrite:error] [pid 13452:tid 1968] [client ::1:51562] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : C:/xamppPortable-x64-php7.3-Pruebas/htdocs/ninja-4.5.18/

    Thanks !!!

    #24457

    Hillel Coren
    Keymaster

    This could be the problem: [Sat Apr 18 23:20:02.931361 2020] [rewrite:error] [pid 13452:tid 1968] [client ::1:51562] AH00670: Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions : C:/xamppPortable-x64-php7.3-Pruebas/htdocs/ninja-4.5.18/

    Maybe this will help: https://stackoverflow.com/questions/11901993/options-followsymlinks-or-symlinksifownermatch-is-off

    #24458

    fartilesj
    Participant

    Thank you !!!.
    The solution was to add in the .htaccess file of the ninja-v4.5.18 folder, inside the directive <IfModule mod_rewrite.c>

    Options + FollowSymLinks

    Again, thanks for helping me

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Posted in: