Home Forums Support Error: address in mailbox given [username] does not comply with RFC 2822, 3.6.2.

This topic contains 3 replies, has 3 voices, and was last updated by  Hillel Coren 1 month, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #910

    mcsilver
    Participant

    I got this on my self-hosted Ubuntu 15.04:

    Address in mailbox given [username] does not comply with RFC 2822, 3.6.2.

    I managed to solve it by editing my .env file, which I have located here:

    /var/www/ninja/.env

    For my SMTP settings, I had entered just my username for MAIL_USERNAME, which does suffice for my ISP but it seems that Invoice Ninja requires the first email address for the username.

    Instead of:
    MAIL_USERNAME=john_doe

    it requires:
    [email protected]

    I hope this helps someone.

    #918

    Hillel Coren
    Keymaster

    Thanks for sharing this!

    #18371

    abiralo
    Participant

    I have given the [email protected] but not working (self-hosted )

    Any idea?

    #18372

    Hillel Coren
    Keymaster

    Are your mail settings correct in the .env file?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Posted in: