Home Forums Support Feature Request: Dashboard Data Boxes compare timeframes

This topic contains 7 replies, has 2 voices, and was last updated by  Hillel Coren 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #19781

    somjuan
    Participant

    Hey there, feature request here:

    The dashboard Data Boxes show all time data by default, compared with a user-selected timeframe. The all time data isn’t terribly useful to me, as several years worth of information isn’t something I ever need.

    I’d love to be able to select both timeframes for comparison purposes, or even just for context (last 7 days vs year-to-date, etc).

    Thanks!

    #19782

    Hillel Coren
    Keymaster

    If you set the first month of year option on Settings > Localization it will change the dashboard to only show this years totals.

    #19783

    somjuan
    Participant

    Hm, that doesn’t seem to work for me, though I’m not sure if perhaps I’m misunderstanding

    If I select “This Year” from the date range, I’ll get the current year’s totals to the right of the All Time totals. I’m looking for the capability to change the “All Time” totals (red arrows below) to a custom range.
    data boxes with arrow

    If I’m misunderstanding what you meant, I’m sorry. I do have the first month of the year set to January.

    • This reply was modified 6 months, 3 weeks ago by  somjuan.
    • This reply was modified 6 months, 3 weeks ago by  somjuan. Reason: BBCode was not the right way
    #19786

    Hillel Coren
    Keymaster

    If it’s set to January the black numbers should be for just this year, if you clear the value it should be for all time.

    The app doesn’t support setting a custom range, feel free to create an issue on GitHub.

    #19787

    somjuan
    Participant

    Bizarre, sounds like I may need to change this into a support request.

    I’ve tried un-setting and re-setting the first month, both to a null selection and to a month other than January. The numbers in blue will change appropriately when the month is a different month, but act as January when set to null. The numbers in black do not change, regardless of the selection.

    Could there be something else I have set messing with this? Thank you for your support.

    #19796

    Hillel Coren
    Keymaster

    I’m not able to get this to work either, feel free to create an issue on GitHub with the behavior you’re looking for.

    #21620

    somjuan
    Participant

    I’ve actually since switched from self-hosted to invoiceninja.com, and this is still the behavior.

    I still can’t tell if there’s a setting somewhere I have misconfigured, but in Localization the first month of the year is set to January, yet I still see all time totals in Black.

    #21630

    Hillel Coren
    Keymaster

    It could be a bug, feel free to create an issue on GitHub to track it.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Posted in: