Home Forums Support How to install Invoice Ninja on Hostgator

This topic contains 28 replies, has 3 voices, and was last updated by  Hillel Coren 3 years ago.

Viewing 29 posts - 1 through 29 (of 29 total)
  • Author
    Posts
  • #2092

    Anonymous

    Hi there,
    I have my own shared host but after I extracted the files from the invoice ninja onto my site, I get a list of files and no prompt to set up the app and database etc.

    Am I missing a step?

    http://invoices.alexpapanicolaou.com/ninja/

    Thanks!

    #2094

    Hillel Coren
    Keymaster

    By default you can access the site using the /public folder.

    The best practice is to configure the site by mapping your webroot to the public folder but you may also be able to change it using the .htaccess file.

    https://coderwall.com/p/erbaig/laravel-s-htaccess-to-remove-public-from-url

    #2096

    Anonymous

    Thanks for the reply.. I tried that with this in my .htaccess file:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule ^(.*)$ public/$1 [L]
    # RewriteRule “^.env” – [F,L]
    RewriteRule “^storage” – [F,L]

    # https://coderwall.com/p/erbaig/laravel-s-htaccess-to-remove-public-from-url
    # RewriteRule ^(.*)$ public/$1 [L]
    </IfModule>

    Here is the URL I’m using with this but I get 500 Internal Server error still…I’m surprised this isn’t straight forward with a simple hostgator server?

    http://invoices.alexpapanicolaou.com/

    #2097

    Hillel Coren
    Keymaster

    I didn’t notice that you’re using a subdomain. In that case you should map you server’s web root to the /public folder use the default .htaccess file.

    #2098

    Anonymous

    Ah ok. So I should go to the main domain and add. Htaccess code in there just like above?

    #2099

    Hillel Coren
    Keymaster

    You shouldn’t need to change the .htaccess file at all, you need to map the webroot to /public.

    #2100

    Anonymous

    How would I do that? Sorry, I’m a newbie to web configs

    #2101

    Hillel Coren
    Keymaster

    It varies, I’d suggest either searching for ‘hostgator laravel’ or contacting your webhost for help.

    #2103

    Anonymous

    So would I need to install Laravel on my shared hostgator account? Not sure why..
    http://laravel.io/forum/02-13-2014-how-to-install-laravel-on-a-hostgator-shared-server

    #2104

    Hillel Coren
    Keymaster

    Our app is a Laravel app so the similar steps should apply, for example making sure you have PHP >= 5.4.

    #2106

    Anonymous

    Oh boy, yeah it looks like that Laravel.io documentation is good until it gets to this part

    “Anyway, open the ‘laravel/bootstrap/paths.php’ file and correct the bootstrap path like this:”

    There isn’t any ‘paths.php’ in the bootstrap directory…stumped…

    #2107

    Hillel Coren
    Keymaster
    #2108

    Anonymous

    Thanks Hillel,
    Was able to update my public_html/index.php it but still getting a 500 Internal Server error when trying to access the ninja invoices page. Any ideas?

    #2109

    Hillel Coren
    Keymaster

    Have you checked your web server error logs for details on the error.

    #2110

    Anonymous

    Here is the error I got..

    [Mon Jan 25 08:38:38 2016] [error] [client 69.136.229.188] SoftException in Application.cpp:313: File “/home3/papanic/public_html/invoices.com/public/index.php” is writeable by group
    [Mon Jan 25 08:35:09 2016] [error] [client 66.249.83.165] SoftException in Application.cpp:313: File “/home3/papanic/public_html/invoices.com/public/index.php” is writeable by group

    #2111

    Hillel Coren
    Keymaster
    #2112

    Anonymous

    Ok that helped…getting somewhere now..but got this error..

    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home3/papanic/public_html/invoices.com/public/index.php on line 52
    
    Parse error: syntax error, unexpected T_STRING in /home3/papanic/public_html/invoices.com/public/index.php on line 52

    I checked index.php line 52 and it shows this…

    51 $response = $kernel->handle(
    52 $request = Illuminate\Http\Request::capture()
    53 );

    #2113

    Hillel Coren
    Keymaster

    That looks like a PHP version issue, can you check which version you’re running.

    #2114

    Anonymous

    I’m on PHP 5.5

    #2115

    Hillel Coren
    Keymaster

    All post I’ve found for this error are related to the PHP version. Is it possible you’re running two separate versions of PHP. It can be helpful to add a phpinfo page to double check the server (vs CLI) version.

    http://stackoverflow.com/questions/17156251/unexpected-character-in-input-ascii-92-state-1
    http://stackoverflow.com/questions/13125007/unexpected-character-in-input-ascii-92-state-1-in-a-silex-application

    https://mediatemple.net/community/products/dv/204643880/how-can-i-create-a-phpinfo.php-page

    #2116

    Anonymous

    Hi Hillel,
    Looks like it worked! I was able to go to Cpanel and go to php config and choose PHP 5.4. Went back to my invoices sub-domain and got access!

    Hi 5!

    #2117

    Hillel Coren
    Keymaster

    Awesome, thanks for sticking with it.

    Let me know if you run into any other problems.

    #2118

    Anonymous

    Thanks Hillel! Hope someone else will benefit from our thread!

    #2119

    Anonymous

    Hillel,
    I’m having trouble setting up the email setting at the startup screen. I couldn’t get the emails to come through with my Gmail SMTP and TCL settings and I just went ahead with the set up. Now I’m getting errors when I try to ‘recover’ the forgotten password.

    “Whoops, looks like something went wrong.

    1/1
    Swift_TransportException in AbstractSmtpTransport.php line 383:
    Expected response code 220 but got code “”, with message “”

    #2120

    Hillel Coren
    Keymaster

    I’d suggest checking your email credentials in the .env file in the root of the folder, if possible try with a different email account.

    There’s an outstanding issue where testing email on the setup screen always shows success.

    #2124

    Anonymous

    Ok, I see I got to the .env file and got the original credentials that I set. Yeah it seems that the email test shows a success when I first did the set up.

    #2647

    Anonymous

    Hi Anonymous and Hillel Coren,

    I can see Anonymous has successfully installed Invoice Ninja on his/her shared hosting. I am facing the same problem. My domain is billing.mydomain.com. I have uploaded all the files. I have also created the database.

    Now what should I do?

    Please….

    #2648

    Anonymous

    Hi,

    I am able to see the setup page. I just have to change the permission of the folder “public” to 755 and now I can see the setup page.

    After providing all the information, now I see this error:

    ErrorException in /home/ogrlega1/public_html/billing/vendor/symfony/process/ProcessUtils.php line 74:
    escapeshellarg() has been disabled for security reasons

    Can you help me guys?

    Thanks

    #2649

    Hillel Coren
    Keymaster

    There’s more info here: https://github.com/invoiceninja/invoiceninja/issues/784

    I believe you’ll either need to temporarily enable escapeshellarg or setup the app from the command line

Viewing 29 posts - 1 through 29 (of 29 total)

You must be logged in to reply to this topic.

Posted in: