Home Forums Support Invoice not sent

This topic contains 14 replies, has 3 voices, and was last updated by  peopleinside 4 weeks, 1 day ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #22417

    peopleinside
    Participant

    Hi,
    the recurring invoice has been sent the first october 2019 than the system show the next invoice schedule send is the first of november.

    Today is the 5 of november and the recurring invoice was still not sent.
    I done manually the cron but no error are showed.

    Once again Invoice Ninja seems have issue on send recurring invoice now how i can solve this issue?
    Thanks.

    screenshot

    Invoice Ninja – v4.5.16
    Apache
    PHP 7.3

    • This topic was modified 2 months, 3 weeks ago by  peopleinside. Reason: Adding invoice version and server informations
    #22419

    Hillel Coren
    Keymaster

    What was the problem last time?

    #22435

    peopleinside
    Participant

    Usually i have issue with recurring invoice.

    Now i deleted the recurring invoice, created an invoice for this month than set a recurring new invoice from December.

    I hope this will fix the issues.
    Thanks

    #22437

    Hillel Coren
    Keymaster

    By ‘issue’ do you mean the invoice isn’t sent, is it generated and not sent or not generated at all.

    If you’re having problems I doubt recreating the invoice will fix it.

    #22438

    peopleinside
    Participant

    Was not generated.
    I will monitor the new recurring invoice and let’s see.
    Now the status in waiting so should be set correctly let’s see if will be sent, if not i will update this discussion.
    Thank you for the support.

    #22440

    Hillel Coren
    Keymaster

    I suggest logging the output from the crons, it can be a big help debugging issues.

    #22472

    CadmiumTelluride
    Participant

    This is due to the PHP version. Please make sure your running PHP 7.2 (Assuming your self-hosting)

    #22473

    peopleinside
    Participant

    Hi, thank you for your message! I use PHP 7.3 as i keep always software updated.
    I have just one doubt and is the recurring invoice was not created correctly.
    I will monitor the new created where now the status is pending so it’s correct.

    #22475

    CadmiumTelluride
    Participant

    Your welcome. I went through the same situation, as you described it, with the recurring statements before i figured it was the php version. If you have a testing environment you can set the job to fire every few minutes so do don’t have to wait for long.

    #22476

    Hillel Coren
    Keymaster

    FYI… the latest version now has support for PHP 7.3 🙂

    https://github.com/invoiceninja/invoiceninja/releases

    #22478

    CadmiumTelluride
    Participant

    Great! My apologies for missing that detail. I’ve updated my self hosting copy, tested the recurring invoice with PHP 7.2, then updated to PHP 7.3 and tested again. The invoice emails where successfully received and the PDFs where successfully generated.

    @peopleinside I withdraw my previous suggestion, because your running the latest version. Like Hillel recommended, you need to get the output from the cron jobs.

    #22479

    Hillel Coren
    Keymaster

    Awesome, glad to hear it! Thanks for the update

    #23036

    peopleinside
    Participant

    Hi Hillel, hope you are well and you enjoy this Christmas time. Don’t know if you celebrate this.

    I have manually sent an recurring invoice because was not automatically sent.
    The invoice was sent at 6 of the month because also if i set to send the first day was not send maybe because customer has no email? I don’t have to send by email to costumer, i have to see generated invoice in the system.

    I was not able to generate the invoice without a valid email address on the customer profile, this is bad for me. I put mine email for be able to send and activate the recurring invoice.

    This caused the invoice was not sent automatically the first of the month as i set so i need force the send at 6 of the month. After done this i removed the email address from the customer as they should not receive by email.
    Now i don’t know if also the next invoice will be not generated because of this anyway is scheduled for the 6 of the next month, I need correct this date to the first of the month.

    In the recurring invoice i see sent on 6 and will send next on 6. How can i edit in the database will be sent on 6 to will be sent on 1?

    Hope in the future you can add the possibility to change this scheduled date from the interface without have to stop the recurring invoice and generate another one.

    Hope also you will insert an option to be not forced to send invoice to the customer who don’t want have sent by email but i need have in the web interface.

    Thanks.

    #23047

    Hillel Coren
    Keymaster

    You can change the start date of the recurring invoice to the next date it should be sent.

    You can also disable auto-emailing of recurring invoices in the workflow section on Settings > Invoice Settings.

    We’re currently working on v2 of the app and will keep this use-case in mind.

    Happy Holidays and have a great new year!

    #23050

    peopleinside
    Participant

    Hi Hillel, thank you for the reply!

    You can change the start date of the recurring invoice to the next date it should be sent.

    Done thanks now status is waiting, Hope to see the invoice sent on the first of Jenuary.

    You can also disable auto-emailing of recurring invoices in the workflow section on Settings > Invoice Settings.

    Option to disable for all client found. I have just one client, maybe will be nice can customize this option for each customer. Again, thanks.

    Happy Holidays and Happy new year!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Posted in: