Home Forums Support Invoices (recurring) not being auto emailed out.

This topic contains 2 replies, has 2 voices, and was last updated by  SemoTech 3 weeks, 2 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #23810

    SemoTech
    Participant

    Running White labeled Self-Hosted v4.5.17 and have an issue with invoices not being auto emailed out.

    1) Have configured “Email Settings” under “System Settings” for SMTP and have received a “Sent” confirmation after pressing [Send Test Email] button
    2) Under “Advanced Settings” / “Email settings” I entered a working address in “BCC Email” and Enabled the option to “Attach PDF”
    3) “Email Style” is “Light”
    4) An Email signature was created
    5) In Settings / Invoice Settings / Workflow Settings / Invoice Workflow “Auto Email” is Enabled!

    Now, when creating a recurring invoice and selecting “Mark Ready” the message “Are you sure you want this invoice emailed?” appears along with the client email. Pressing [YES] sets the invoice to “Pending” and should email the invoice, but it does not! – I tested this with my own email aliases and nothing!

    Only after marking Ready, if one then presses the orange [Email Invoice] button, an “Are you sure?” message pops-up. Pressing [YES] yelds a “Email sent successfully” momentary message, and the Invoice status changes to “Active”. Invoice is then finally emailed, and I also get a confirmation.

    Seems like the {Automatically email recurring invoices when they are created} feature in Invoice Workflow “Auto Email” is not working!

    Also, how do I change the text/layout of the BCC notification emails I receive? Should that template not be in Settings / Templates & Reminders?

    Thank you.

    #23820

    Hillel Coren
    Keymaster
    #23878

    SemoTech
    Participant

    YES Hillel, the crons were enabled! (tho I had to do it manually as the Softaculous installation failed to do it)

    The issue with invoices not being emailed out had to do with the “Driver” Invoice Ninja uses for sending email and allows one to configure under Email Settings. Seems the “SMTP’ option was not working and I had to change to “SendMail” to make invoices get sent out using TLS for Office 365. See my post on GitHub HERE

    The settings are:

    Driver:  SendMail
    Server Address: smtp.office365.com
    Username: Your Office 365 Email/Address
    Password: Your Office 365 Password
    Port Number: 587
    Encryption: TLS

    All emailing out solid now!

    • This reply was modified 3 weeks, 2 days ago by  SemoTech.
    • This reply was modified 3 weeks, 2 days ago by  SemoTech.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Posted in: