Home Forums Support Not receiving notifications

This topic contains 10 replies, has 2 voices, and was last updated by  kidjake28 1 week, 2 days ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #20908

    kidjake28
    Participant

    Self-hosted 4.5.13

    Seems like this issue started when upgraded to 4.5.13.

    I’m not getting email notifications (when invoices, viewed, paid etc).

    Not sure where to start looking for this issue.Any help appreciated.

    #20911

    Hillel Coren
    Keymaster

    – Which version did you upgrade from?

    – Are notifications enabled on Settings > Notifications?

    Note: viewed notifications aren’t sent if you view an invoice while logged in as an admin.

    #20916

    kidjake28
    Participant

    Thanks for the reply.

    I upgraded from 4.5.12.

    Notifications are enabled for me. I usually get notified when a client views their invoice OR when recurring invoices get sent out.

    Is there a log I can check?

    #20917

    Hillel Coren
    Keymaster

    I’m not sure what would cause it, the changes in 4.5.13 were very minor.

    #20918

    kidjake28
    Participant

    Is there an email log I can look at for outgoing emails?

    #20919

    Hillel Coren
    Keymaster

    Only with Postmark for client emails, you’d need to check your email provider.

    #20920

    kidjake28
    Participant

    So I checked my notification settings and I’ve selected ‘Email me when invoice is’ SENT, VIEWED and PAID for ALL invoices.

    I’ve checked my outgoing mail server and I do see emails going out but none are addressed to me.

    For instance there is a PAYMENT RECEIVED email for our billing email account to the client. I’m not cc’d or bcc’d anywhere in the email?

    #20921

    Hillel Coren
    Keymaster

    You can set a BCC on Settings > Email Settings

    #20977

    kidjake28
    Participant

    Is there anything you can help me with?

    Let me recap.

    Upgraded from 4.5.12 -> 4.5.13

    Admin users are no longer getting any of the notification messages.(These are the only settings we’ve selected)
    1)Email me when an invoice is sent
    2)Email me when an invoice is viewed
    3)Email me when an invoice is paid

    I’ve checked the SMTP settings and they are correct. Recurring and invoices are being sent out as I can see them in the sent folder of the gmail account being used. I’m also able to run an SMTP test without any errors.

    Under email settings
    There is nothing defined in the Reply-To-Email and BCC email settings.

    So at this point I would love an idea of where to start looking for where the problem might be?

    #20985

    Hillel Coren
    Keymaster

    You may want to see if downgrading to v4.5.12 fixes the problem.

    #20987

    kidjake28
    Participant

    Yes I did that….waiting to see if it works.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Posted in: