Home Forums Support Pay Now button doesnt work…

This topic contains 8 replies, has 3 voices, and was last updated by  lordpayder 4 months, 4 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #17783

    brianfox
    Participant

    Just setup a new install of InvoiceNinja on a new server…and when processing payment (using Stripe)…form accepts entry, and I press “Pay now” and nothing happens…no error, no payment, nothing.

    Looking in the logs I see the following: (this is partial)

    production.ERROR: Uncaught TypeError: Cannot read property ‘value’ of null {“context”:”JavaScript”,”user_id”:0,”account_id”:0,”user_name”:””,”method”:”GET”,

    Any ideas? I checked my SSL cert, and its good, and see no errors in Stripe.

    #17786

    Hillel Coren
    Keymaster

    Do you see any errors in the browser console?

    Also, make sure you have the billing address enabled in the payment gateway settings.

    #17790

    brianfox
    Participant

    There were no errors in the browser console…but when I check “Require client to provide their billing address” the payment now processes. I’d prefer not to have them type in their billing address— is there a reason for this behavior? Can I uncheck something on Stripe to not require this?

    #17791

    Hillel Coren
    Keymaster

    It’s a bug, we should have a fix in our next minor release.

    Note: I think you’ll need to check that you aren’t requiring the zip code in the Stripe settings.

    #17792

    brianfox
    Participant

    I looked everywhere in Stripe and cannot see anything that says require ZIP….am I missing it somewhere?

    Thanks for the quick feedback— I’ll look forward to the update.

    #17793

    Hillel Coren
    Keymaster
    #17859

    lordpayder
    Participant

    Same problem.
    I disabled the requirement of entering any user information, only name and credit card information.

    https://invoice.myurl.de/log_error?error=Uncaught%20TypeError%3A%20Cannot%20read%20property%20%27value%27%20of%20null&url=https%3A%2F%2Finvoice.myurl.de%2Fpayment%2Fs4f42dg4ae92qdvbzoqgulrpvn9fxiiq%2Fcredit_card

    The above mentioned workaround with disabling the avs-check rule did not help solving this.

    I’m running v4.5.7 self hosted.

    #17860

    Hillel Coren
    Keymaster

    For it to work in v4.5.7 you’ll need to show the address.

    #17861

    lordpayder
    Participant

    Yeah, I know that it works with the address.
    Just wanted to confirm that it’s not working without and the stripe rule has nothing to do with it.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Posted in: