Home Forums Support Problem after upgrading to v4.5.16

This topic contains 3 replies, has 2 voices, and was last updated by  gdrak0 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #22960

    gdrak0
    Participant

    Hello
    After upgrading to v4.5.16 there was a problem processing the payment gateways.
    Please see the problem below..

    (1/1) RuntimeException

    Class ‘\Omnipay\VivaPayments\RedirectGateway’ not found
    in GatewayFactory.php (line 105)
    at GatewayFactory->create(‘\\Omnipay\\VivaPayments\\RedirectGateway’)
    at call_user_func_array(array(object(GatewayFactory), ‘create’), array(‘VivaPayments_Redirect’))in Omnipay.php (line 115)
    at Omnipay::__callStatic(‘create’, array(‘VivaPayments_Redirect’))in Gateway.php (line 217)
    at Gateway->getFields()in AccountGatewayController.php (line 138)
    at AccountGatewayController->getViewModel(object(AccountGateway))in AccountGatewayController.php (line 61)
    at AccountGatewayController->edit(‘3’)
    at call_user_func_array(array(object(AccountGatewayController), ‘edit’), array(‘gateways’ => ‘3’))in Controller.php (line 54)
    at Controller->callAction(‘edit’, array(‘gateways’ => ‘3’))in ControllerDispatcher.php (line 45)
    at ControllerDispatcher->dispatch(object(Route), object(AccountGatewayController), ‘edit’)in Route.php (line 212)
    at Route->runController()in Route.php (line 169)
    at Route->run()in Router.php (line 658)…..

    Thank you in advance..
    George

    #22967

    Hillel Coren
    Keymaster

    The latest version is 4.5.17 but I don’t think that should matter.

    Did you get the code from GitHub or are you using the self host zip?

    #22969

    gdrak0
    Participant

    I use self host zip and for gateway this script..
    https://www.babel.com.au/docs/omnipay-vivapayments/class-Omnipay.VivaPayments.RestGateway.html

    Everything worked properly for 2 years until the update.
    The update process was done by copy over the latest code
    Is there anything that could affect the function?

    Thank you

    #22976

    gdrak0
    Participant

    Hi to all

    The problem was solved by running from the root “composer require delatbabel/omnipay-vivapayments”

    Best Regards
    George

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Posted in: