Home Forums Support Quotes approved are archived despite quote workflow parameters

This topic contains 13 replies, has 3 voices, and was last updated by  paroiron 3 weeks, 6 days ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #16340

    paroiron
    Participant

    Hi,
    I’m using Invoice Ninja 4.5.4 self hosted for my workshop, localhost only, single user.
    I have a problem with quotes, that are archived when marked approved, despite the following settings :
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoConvert disabled
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoArchive disabled

    Is there anything I’m missing ?

    #16344

    Hillel Coren
    Keymaster

    I’m not sure, I haven’t been able to reproduce the problem.

    #16350

    paroiron
    Participant

    Thank you for your answer. I’m feeling a little bit awkward for now because I’m struggling with this problem for 2 weeks now, and it worked today. The only thing I can think of is that I’ve switched to English and back to French (so that I can post this message with the correct english option/menu names). Is there any way that switching back to English can solve this ? That’s quite a mistery. I’ve read that for some phantomJS thingees on Invoice Ninja, switching back to English can solve problems.

    Anyway, it’s working now.

    #16351

    Hillel Coren
    Keymaster

    I’m not sure, but I’m glad to hear it’s working!

    #19255

    paroiron
    Participant

    Hi,
    same problem again, switching languages back and forth or working in English does not solve anything anymore but I figured out why you weren’t able t reproduce it and why it suddenly worked when I first opened the subject !

    It looks like Invoice Ninja mistakes InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoConvert for InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoArchive when approving a quote. Here’s what I was able to reproduce 10 times out of 10 :

    — 1st case :
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoConvert disabled
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoArchive disabled
    -> everything works as it should

    — 2nd case :
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoConvert enabled
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoArchive disabled
    -> everything works as it should

    — 3rd case :
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoConvert enabled
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoArchive enabled
    -> everything works as it should

    — 4th case :
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoConvert disabled
    InvoiceSettings>WorkflowSettings>QuoteWorkflow>AutoArchive enabled
    -> Here I’ve got a problem : approving a quote marks it ‘approved’ AND archives it. It would be logical that approving a quote only marks it ‘approved’ and that archiving occurs when converting it to an invoice. 4th case’s bug does not show in 3rd case because (marking approved)+(converting to invoice)+(archiving the quote) is the expected workflow.

    Last time I reported the bug, in my second message I was indeed in 1st case instead of 4th case, my mistake.

    #19256

    Hillel Coren
    Keymaster

    From your description it seems to be working as designed?

    #19259

    paroiron
    Participant

    Thank you for your answer. Based on my understanding of the AtutoArchive flag (i.e. “Automatically archive quotes when they are converted.”) I disagree. Converting a quote is not approving it, isn’t it ? Therefore workflow should be the following in 4th case :
    create quote-> approve quote-> quote is approved and not archived-> convert to invoice when job is done-> quote is automatically archived while invoice is created from quote
    Instead I have :
    create quote-> approve quote-> quote automatically archived while no invoice is created whicj leads to an archived approved quote never converted to an invoice yet-> you have to restore quote to convert it to an invoice, which is weird.

    If that’s not supposed to work like this, then why having separated Autoconvert and Autoarchive flags ?

    Thank you for your help !

    #19260

    Hillel Coren
    Keymaster

    Hmm… that’s a good point, I’ll look into it.

    #19261

    paroiron
    Participant

    Thank you very much ! Invoice ninja works great for me besides this !

    #21282

    paroiron
    Participant

    Hi, any news on this subject ? Thank you.

    #21284

    Hillel Coren
    Keymaster

    I believe there may be a fix for this in the next release in a few weeks.

    Our focus is on v2, v1 is getting much less attention these days.

    #21294

    paroiron
    Participant

    Yes, I guess V2 is using a lot of your resources. Thank you for the update, I hope the fix will make its way through the next release !

    #21697

    Motor
    Participant

    I’m having this same issue I think.. We are confusing all our customers as when they approve a quote, it instantly sends them an invoice for what they approved. We want the invoice to generate, but remain a draft, as work is typically exploratory and we usually have to update the invoice during the course of work and then when the work is all done, then we want to send the invoice to the customer. I like them to be able to see the current standing of the invoice while its in progress… its nice for them to be able to follow along in their portal during the course of the work, but we dont want it to be emailed to them before the work is done.

    How can I make this work? Currently the only option I see is:
    “:Auto Convert
    Enable
    Automatically convert a quote to an invoice when approved by a client.”

    Is there any way to have it automatically convert to invoice, although NOT email them the invoice until we tell it to?

    • This reply was modified 1 month, 2 weeks ago by  Motor.
    #22023

    paroiron
    Participant

    I’m not sure the problem is the same. Have You tried invoice_parameters/workflow_parameters/invoice_workflow/automatically_send_invoices : disabled (not sure of the translation, I hope you’ll find).

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

Posted in: