Home Forums Support Recover Password not Working for me

This topic contains 9 replies, has 2 voices, and was last updated by  Titanfail 1 month ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #16920

    ideasgirl
    Participant

    Hello,

    I installed and played a little bit last week with the self hosted option. I thought I saved my user/pass to the admin panel but today when I was going to go in again to get some more config done I didn’t have such info on my saved file of passwords.

    I tried to used the recover password option but the email never arrived. I then changed the email on the database of users and it wasn’t received on that email neither. What other resource I have to get this password back? or reset it. I could start all over and lose 1 day of work and tests, but what if it happens in the future? then I don’t have a way to get the password, or even a customer, which I’ve seen others talking about it.

    Thanks in advance,
    IDEASGirl

    #16921

    Titanfail
    Participant

    Did you try clearing the DB cache after changing the email address? http://yourninjaurl/?clear_cache=true

    Also make sure to double-check the mail settings in your .env file for MAIL_PORT, MAIL_HOST, MAIL_USERNAME, and MAIL_PASSWORD.

    #16922

    ideasgirl
    Participant

    Did you try clearing the DB cache after changing the email address?

    Yes, sir.

    Also make sure to double-check the mail settings in your .env file for
    I have those values blank on that file. I believe I didn’t get to set them. If I do now, and I don’t have emails set on this host, what should I do?

    #16923

    Titanfail
    Participant

    That’s likely your problem then. If there are no mail settings in the .env file, then the app won’t know how to send emails (including password recovery). I just use a gmail account on mine. You can enable SMTP in your gmail account by following this guide: https://www.digitalocean.com/community/tutorials/how-to-use-google-s-smtp-server

    Once that’s setup, make sure you have the following set in your .env file.

    MAIL_DRIVER=smtp
    MAIL_PORT=465
    MAIL_ENCRYPTION=ssl
    MAIL_HOST=smtp.gmail.com
    [email protected]
    MAIL_FROM_NAME='Your Name'
    MAIL_PASSWORD=yourpassword
    

    That should enable the application to send emails (change the last three lines, obviously), and let you recover/reset your password.

    #16924

    ideasgirl
    Participant

    That didn’t work. I’m missing MAIL_FROM_ADDRESS= not sure if that’s the problem. I also added a new email to the host account and tried that smtp and no success.

    I do see the password_reset requests on the db.

    #16925

    Titanfail
    Participant

    Long shot, but care to paste your .env after redacting any passwords or keys?

    #16926

    ideasgirl
    Participant

    Sure:

    APP_ENV=production
    APP_DEBUG=false
    APP_LOCALE=en
    APP_URL=https://ideas4net.com/billing/public
    APP_KEY=***
    APP_CIPHER=AES-256-CBC
    REQUIRE_HTTPS=true
    DB_TYPE=mysql
    DB_HOST=localhost
    DB_DATABASE=***
    DB_USERNAME=***
    DB_PASSWORD=***
    MAIL_DRIVER=smtp
    MAIL_PORT=465
    MAIL_ENCRYPTION=ssl
    MAIL_HOST=smtp.ideas4net.com
    [email protected]
    MAIL_FROM_NAME=IDEAS
    MAIL_FROM_ADDRESS=
    MAIL_PASSWORD=***
    PHANTOMJS_CLOUD_KEY=a-demo-key-with-low-quota-per-ip-address
    PHANTOMJS_SECRET=***
    MAILGUN_DOMAIN=
    MAILGUN_SECRET=
    • This reply was modified 1 month ago by  ideasgirl.
    #16928

    Titanfail
    Participant

    Only thing I can think of off the top of my head would be to check your mailserver logs and see if it’s rejecting the login from IN.

    #16929

    ideasgirl
    Participant

    How?

    #16930

    Titanfail
    Participant

    Might need to get in contact with whoever you have your email hosted with and make sure everything’s good on their end. And also that they’re actually allowing connections from the IP your IN server is running on.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Posted in: