Home Forums Support Recurring invoice set to draft instead of sent

This topic contains 9 replies, has 2 voices, and was last updated by  Hillel Coren 2 months, 2 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #20519

    studio luminous
    Participant

    With my self-hosted Invoice Ninja I set up a recurring invoice for the 24th of each month with it set to autobill. A new invoice was created but it is set to draft and wasn’t billed or emailed. The due date is the same as the creation date if that helps. Any thoughts? I don’t see any log errors in any of the log files.

    #20520

    studio luminous
    Participant

    Invoice ninja version 4.5.12

    #20524

    Hillel Coren
    Keymaster

    Can you check auto-email is enabled in the workflow section on Settings > Invoice Settings.

    #20526

    studio luminous
    Participant

    Thanks. It wasn’t but I actually didn’t want the invoice to be emailed out, just the invoice paid/autobilled and then sent a receipt. If I understand the workflow, if I have the auto email function turned on then they will receive an invoice and then a receipt in very close proximity to one another. Is that correct?

    #20527

    Hillel Coren
    Keymaster

    If they have a card on file they should be auto billed and will receive a “Thanks for your payment” email.

    #20528

    studio luminous
    Participant

    That’s exactly what I want. I just want to make sure they won’t receive and invoice if they have a card on file, just a receipt. If that’s the case that’s great! Thank you.

    #20645

    studio luminous
    Participant

    So it turns out that this doesn’t work. I have a recurring invoice set to auto bill and I had changed the email settings to send when generated. The card on file was not billed and the customer was sent an invoice, not a receipt. How do I get invoices to be paid automatically? I don’t want my customers to receive an invoice, just a receipt of payment.

    #20648

    Hillel Coren
    Keymaster

    Maybe auto billing failed for the invoice? You can check the card on file using the ‘view in portal’ link.

    You may also want to check that autobill is set to always for the recurring invoice and it’s set to send date on Settings > Online Payments.

    #20653

    studio luminous
    Participant

    The card is fine and I had the invoice set to always autobill. I didn’t have it on send date, I had it on due date which was the same day. What is the setting for if it doesn’t autobill on the due date?

    #20654

    Hillel Coren
    Keymaster

    Not sure I follow, the setting enables selecting between the two dates if they’re different.

    If you store the output from the crons there may be more details there.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Posted in: