Home Forums Support Recurring invoices not being sent (yet?)

This topic contains 2 replies, has 2 voices, and was last updated by  jbakuwel 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #17265

    jbakuwel
    Participant

    Hi,

    I just created my first bunch of recurring invoices. They are all sitting pretty in Invoice Ninja with status “Pending”. Running the cron job manually doesn’t find any recurring invoices though. The time zone is NZDT (New Zealand); UTC is 13 hrs behind.

    [email protected]:~$ date
    Wed Dec 5 12:26:08 NZDT 2018

    [email protected]:~$ /usr/bin/php /var/www/clients.omiha.com/artisan ninja:send-invoices
    Tue, 04 Dec 2018 23:26:16 +0000 Running SendRecurringInvoices…
    Tue, 04 Dec 2018 23:26:16 +0000 0 recurring invoice(s) found
    Tue, 04 Dec 2018 23:26:16 +0000 0 recurring expenses(s) found
    Tue, 04 Dec 2018 23:26:16 +0000 Done
    [email protected]:~$

    MariaDB [invoiceninja]> select start_date, last_sent_date from invoices;
    +————+—————-+
    | start_date | last_sent_date |
    +————+—————-+
    | 2018-12-05 | NULL |
    | 2018-12-05 | NULL |
    | 2018-12-05 | NULL |
    | 2018-12-05 | NULL |
    | 2018-12-05 | NULL |
    | 2019-10-01 | NULL |
    | 2018-12-05 | NULL |
    | 2018-12-05 | NULL |
    | 2018-12-05 | NULL |
    | 2019-02-01 | NULL |
    | NULL | 2018-12-04 |
    +————+—————-+
    11 rows in set (0.00 sec)

    I have specified the correct time zone (Pacific/Auckland) in both /etc/php/7.0/cli/php.ini and /etc/php/7.0/apache2/php.ini. I’ve also selected the correct time zone in Settings – Localization.

    I expect that this all will work in the afternoon but wonder how I can tell php and/or artisan to use the local time instead of UTC as presumably that is why the recurring invoices haven’t been found yet.

    Any suggestions?

    Jan

    #17296

    Hillel Coren
    Keymaster

    Were the invoices sent, I think the app expects the servers to be UTC.

    #17321

    jbakuwel
    Participant

    Hi Hillel,

    Thanks for the reply.

    The invoices were sent in the afternoon as expected. The server’s hardware clock is set to UTC but of course the local time depends on the time zone. Maybe something for the wish list? Easy enough to work around it but there may be other parts of the software where an accurate local time is more important.

    regards,
    Jan

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Posted in: