Home Forums Support [Self-Hosted] $account.country.name variable not displaying country

This topic contains 8 replies, has 3 voices, and was last updated by  Hillel Coren 1 month, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #22912

    shahz
    Participant

    For some weird reasons, $account.country.name variable is not showing the country name. It also doesn’t show if I use $accountAddress variable. I have already added my country in the Company Details under settings. All other details appear perfectly fine.

    Additionally, there is no variable for Email? $account.email doesn’t appear in the variables modal too. I have also filled in the email already in the company details.

    Any idea? I’m using version 4.5.17

    • This topic was modified 3 months, 3 weeks ago by  shahz. Reason: adding email bug
    #22914

    shahz
    Participant

    Oh, even $account.website variable doesn’t exist too.. I’ll keep adding them here as I discover..
    For now, I’m just hard-coding the values instead..

    • This reply was modified 3 months, 3 weeks ago by  shahz.
    #22919

    Hillel Coren
    Keymaster

    I think for email you need to use $account.workEmail, I’m not sure why the other ones aren’t working though.

    #23666

    user
    Participant

    Same here, $account.country.* and $client.country.* don’t work. self hosted version 4.5.17.

    #23671

    Hillel Coren
    Keymaster

    Did they work in a previous release?

    #23673

    user
    Participant

    Sorry, don’t know. I changed my invoices only days ago with the current release installed.
    $account.countryId shows the correct id. can i debug/verbose it somehow?

    #23674

    Hillel Coren
    Keymaster

    Hmm.. it may depend on context, for example the preview on /invoices/edit vs clicking “View in portal” to preview it in the portal.

    #23675

    user
    Participant

    ohh, yes. only in desing editor it doesn’t work. sorry.

    thank you.

    #23676

    Hillel Coren
    Keymaster

    Great, glad to hear it!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Posted in: