Home Forums Support [Self-Hosted] symlink "public/setup" not generating

This topic contains 5 replies, has 2 voices, and was last updated by  Hillel Coren 2 weeks, 2 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #23489

    iard96
    Participant

    Greetings!

    This is my first time attempting to install Invoice Ninja as a self-hosted project. I’ve followed several tutorials attempting to reach the setup page. I’ve generated a MySQL database for it, edited the configuration files, ran Composer without errors, and have Apache pointing to the unzipped directory with configuration to follow symlinks. However, when navigating to the “public” directory in the web browser, it attempts to redirect to “public/setup” and gives me the following error: “The requested URL was not found on this server.” Looking at the file structure itself, there is no “public/setup”, symlink or otherwise. I’m not sure if that’s supposed to be generated or where, but there are no errors I found in the laravel-error log.

    Current Versions:
    PHP – 7.2
    InvoiceNinja – 4.5.17
    Apache – 2.4.29

    #23490

    Hillel Coren
    Keymaster

    We suggest mapping the webroot to the /public folder, it may help with the error you’re seeing.

    #23492

    iard96
    Participant

    Thank you for the fast reply Hillel!

    It was able to resolve that error. However, the setup page, while it loads, does not seem to have functioning buttons nor any accompanying CSS to it. Rather, it looks very minimalistic – with only plain text, undecorated buttons, and simple text fields, but with none of the buttons actually functioning I can’t even submit the setup configuration as the filled out form. I did see some other users encounter similar issues, where they failed to specify Directory information within the VirtualHost (Apache Configuration). However, that is specified on my end and I’m not really sure how to proceed.

    Thank you again for helping this newbie!

    #23494

    iard96
    Participant

    I poked around the other forum posts which encountered similar issues, and it is was an issue others faced before: forcing an SSL connection causing a mixed content error, which I resolved by modifying .env to REQUIRE_HTTPS=true. However, I’m now getting a redirect loop error and I’ve tried some other methods as suggested to resolve this to no avail. I’d assume at this point it’s not an InvoiceNinja issue and rather has to do with my Apache configuration and SSL certificate.

    Thank you again for the help and hopefully, I’ll be able to get this resolved.

    • This reply was modified 2 weeks, 2 days ago by  iard96.
    #23496

    iard96
    Participant

    So I did have some issues with my Apache configuration which I was able to resolve after setting the root directory to [invoiceninja]/public, however, after resolving the redirection issues, I’m still getting a 404 error when hitting the root directory (which redirects to [rootdir]/setup). I also did a fresh file installation from the zip folder so no Composer configuration this time. This tells me the symlink still isn’t generating, or I skipped a step somewhere in the installation process.

    #23499

    Hillel Coren
    Keymaster

    ‘/setup’ isn’t a symlink, the routes in the Larvel app are defined in routes/web.php

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Posted in: