Home Forums Support Self-Hosted v4.5.9 – Cron Job Errors

This topic contains 4 replies, has 2 voices, and was last updated by  phobes 3 weeks, 4 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18662

    phobes
    Participant

    Trying to get cron jobs working but I’m getting the the following errors:

    PHP Warning: Unsupported declare 'strict_types' in /RETRACTED/vendor/sabre/uri/lib/functions.php on line 1
    PHP Parse error: syntax error, unexpected ':', expecting '{' in /RETRACTED/vendor/sabre/uri/lib/functions.php on line 23

    PHP 7.2.11 is installed for both my website and shell account, configuration for each is below

    Web

    ./configure
    --prefix=/usr/local/php72
    --datadir=/usr/local/php72/share
    --localstatedir=/usr/local/php72/var
    --without-pear
    --with-config-file-path=/etc/php72
    --with-config-file-scan-dir=/etc/php72/conf.d
    --with-zend-vm=GOTO
    --enable-cgi
    --enable-fpm
    --enable-libxml=shared
    --enable-bcmath=shared
    --enable-calendar=shared
    --enable-ctype=shared
    --enable-dom=shared
    --enable-exif=shared
    --enable-fileinfo=shared
    --enable-filter=shared
    --enable-ftp=shared
    --enable-hash
    --enable-intl=shared
    --enable-json=shared
    --enable-mbstring
    --enable-mbregex
    --enable-mbregex-backtrack
    --enable-opcache
    --enable-pcntl=shared
    --enable-pdo
    --enable-phar=shared
    --enable-posix=shared
    --enable-session=shared
    --enable-shmop=shared
    --enable-simplexml=shared
    --enable-soap=shared
    --enable-sockets=shared
    --enable-sysvmsg=shared
    --enable-sysvsem=shared
    --enable-sysvshm=shared
    --enable-tokenizer=shared
    --enable-wddx=shared
    --enable-xml=shared
    --enable-xmlreader=shared
    --enable-xmlwriter=shared
    --enable-zip=shared
    --with-openssl=shared
    --with-kerberos
    --with-pcre-regex
    --with-sqlite3
    --with-zlib=shared
    --with-bz2=shared
    --with-curl=shared
    --with-gd=shared
    --with-jpeg-dir=/usr
    --with-png-dir=/usr
    --with-zlib-dir=/usr
    --with-xpm-dir=/usr
    --with-freetype-dir=/usr
    --with-gettext=shared
    --with-gmp=shared
    --with-mhash=shared
    --with-iconv=shared
    --with-imap=shared
    --with-imap-ssl
    --with-mcrypt=shared
    --with-mysql-sock=/No-MySQL-hostname-was-specified
    --with-mysqli=shared,mysqlnd
    --with-pdo-mysql=shared,mysqlnd
    --with-pdo-pgsql=shared
    --with-pdo-sqlite
    --with-pgsql=shared
    --with-pspell=shared
    --with-readline=shared
    --with-tidy=shared
    --with-xmlrpc=shared
    --with-xsl=shared
    --with-sodium
    --with-password-argon2=/usr'

    Shell

    [ps605255]$ php -v
    PHP 7.2.11 (cli) (built: Oct 16 2018 18:51:28) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
        with Zend OPcache v7.2.11, Copyright (c) 1999-2018, by Zend Technologies
    
    [ps605255]$ php -me
    [PHP Modules]
    bcmath, bz2, calendar, Core, ctype, curl, date, dom, exif, fileinfo, filter, ftp
    gd, gettext, hash, iconv, imagick, imap, json, libxml, mbstring, memcached, mysqli
    mysqlnd, openssl, pcntl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, pspell
    Reflection, session, SimpleXML, soap, sockets, sodium, SPL, sqlite3, standard
    tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend OPcache, zip, zlib
    
    [Zend Modules]
    Zend OPcache
    • This topic was modified 3 weeks, 5 days ago by  phobes.
    #18664

    Hillel Coren
    Keymaster

    I’m not sure, when googling for the error most answers mention the PHP version?

    #18665

    phobes
    Participant

    Yes sir I made sure I’m running an adequate PHP version, does Fast CGI make a difference at all, or do I appear to be missing a necessary extension?

    #18666

    Hillel Coren
    Keymaster

    Sorry, the only cause I’m aware of for this error is PHP version.

    #18705

    phobes
    Participant

    Ahh, figured it out! My host installs multiple versions of PHP so I had to specify /usr/local/php72/bin/php and it ran successfully! Thanks again for your prompt assistance 🙂

    Also important to note, the reminders would NOT send until I added a Payment Term! I’m not sure if this is specific to me but figured I would add it here just in case.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Posted in: