Home Forums Support Self-hosting : Error 404 trying to setup

This topic contains 5 replies, has 3 voices, and was last updated by  Robink 2 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11816

    kebel87
    Participant

    Hi all!

    I installed InvoiceNinja on a subdomain, without setting SSL.

    So, my root is /var/www/domain.com/html/ninja/public and can be accessed by http://ninja.domain.com

    The root is set as such in the file located at /etc/NGINX/sites-available/domain.com

    I’m using Debian, NGINX, PHP7.0-FPM and MariaDB.

    My problem is that everytime I want to reach http://ninja.domain.com (or if I browse http://ninja.domain.com/index.php), it rewrite the adress bar to show http://ninja.domain.com/setup (or http://ninja.domain.com/index.php/setup) which result in an error 404 page not found.

    Is there any guru here that could help me or point what I should look into? I think I’m close to make it work but needs to get over that issue.

    Thanks!

    #11818

    Hillel Coren
    Keymaster

    If you’re seeing index.php in the URL it usually means mod rewrite needs to be enabled.

    #11820

    kebel87
    Participant

    I’m not seeing it unless I specifically put it in the address bar.

    If i browse http://ninja.domain.com the address bar get changed to http://ninja.domain.com/setup and it returns error 404.

    Thanks for helping me!

    #11821

    Hillel Coren
    Keymaster

    Is mod rewrite enabled?

    #11822

    kebel87
    Participant

    Thanks Hillel,

    by insisting on mod_rewrite, you had me understand that NGINX doesn’t follow .htaccess. I had to add

    ” try_files $uri $uri/ /index.php?$args; ”

    in the domain.com config file under server ninja.domain.com location.

    #20402

    Robink
    Participant

    Guys, your posts made my monday, finally got to get to the invoice ninja install screen… pfew ! and thanks to that last comment of kebel87 where he mentions Hillel insistence…

    Well Hillel, you’ve just shot two birds with one stone… (solved at 6am), but still 🙂

    Much appreciated guys

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Posted in: