Home Forums Support Support for omnipay/common

This topic contains 0 replies, has 1 voice, and was last updated by  icecappacino 1 month, 1 week ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #16847

    icecappacino
    Participant

    hey guys I have a situation here where I could use some advice figuring out….I’m use to using composer but when it comes to package incompatibility issues I get a bit confused as to resolving them I am trying to install a payment gateway I developed and I get the following when trying to install it via composer

    remote: Problem 1
    remote: – Conclusion: remove omnipay/common 2.5.2
    remote: – Conclusion: don’t install omnipay/common 2.5.2
    remote: – Conclusion: don’t install omnipay/common v2.5.1
    remote: – Conclusion: don’t install omnipay/common v2.5.0
    remote: – Conclusion: don’t install omnipay/common v2.4.1
    remote: – Conclusion: don’t install omnipay/common 2.4.0
    remote: – Conclusion: don’t install omnipay/common v2.3.4
    remote: – Conclusion: don’t install omnipay/common v2.3.3
    remote: – Conclusion: don’t install omnipay/common 2.3.2
    remote: – Conclusion: don’t install omnipay/common v2.3.1
    remote: – Installation request for invoiceninja/omnipay-collection ^0.9.0 -> satisfiable by invoiceninja/omnipay-collection[v0.9].
    remote: – Conclusion: don’t install omnipay/common 2.5.x-dev
    remote: – collizo4sky/omnipay-wepay dev-address-fix requires omnipay/common ~2.3 -> satisfiable by omnipay/common[2.5.2, 2.3.2, 2.4.0, 2.5.x-dev, v2.3.0, v2.3.1, v2.3.3, v2.3.4, v2.4.1, v2.5.0, v2.5.1].
    remote: – collizo4sky/omnipay-wepay dev-address-fix requires omnipay/common ~2.3 -> satisfiable by omnipay/common[2.5.2, 2.3.2, 2.4.0, 2.5.x-dev, v2.3.0, v2.3.1, v2.3.3, v2.3.4, v2.4.1, v2.5.0, v2.5.1].
    remote: – Conclusion: don’t install omnipay/common v2.3.0
    remote: – Installation request for collizo4sky/omnipay-wepay dev-address-fix -> satisfiable by collizo4sky/omnipay-wepay[dev-address-fix].
    remote:

    what is it trying to tell me here?
    my package has the following requirements

    "require": {
        "php": ">=5.4.0",
        "omnipay/common": "~2.0"
      },

    is it that the overall application cannot support the dep “omnipay/common > 2.3.0” ?

    • This topic was modified 1 month, 1 week ago by  icecappacino. Reason: formatting
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Posted in: