Home Forums Support Template footer overlap

This topic contains 11 replies, has 3 voices, and was last updated by  Hillel Coren 2 years, 8 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #5069

    tombro
    Participant

    Hi,

    I’m using the “bold” template for my invoices and quotes. When I create a big invoice or quote, the text of my line items is under the footer-layer. I thought setting a page-margin would solve this problem, but the page margin also affects the position of the footer. One way to avoid is, is to only show the footer on the last page, but I would like to show the footer on every page.

    Any suggestions?

    #5072

    Hillel Coren
    Keymaster

    You may be able to fix this by adjusting the footer position as well as the page margin.

    #5724

    Anonymous

    Hi.

    I have the same problem. On which tab can I adjust the page margin? Footer position can be adjusted on tab footer I suppose. There I have the following values:

    {
    “columns”: [
    {
    “text”: “$invoiceFooter”,
    “alignment”: “center”
    }
    ],
    “margin”: [
    40,
    20,
    40,
    20
    ]
    }

    Thanks for any suggetions 🙂

    #5725

    Hillel Coren
    Keymaster

    The page margins can be adjusted on the ‘Margins’ tab.

    #5732

    Anonymous

    Hi Hillel

    Thank you for the fast response, but I can still not solve the problem.
    Here is my configuration:

    Footer tab:
    {
    “columns”: [
    {
    “text”: “$invoiceFooter”,
    “alignment”: “center”
    }
    ],
    “margin”: [
    40,
    100,
    40,
    0
    ]
    }

    Margins tab:
    [
    60,
    140,
    40,
    180
    ]

    So the page margin-bottom is 180px, and the footer margin-top is 100px. The table still overlaps the footer…
    Do you have an idea how to solve this?

    #5737

    Hillel Coren
    Keymaster

    Have you tried increasing the page margins?

    #5738

    Anonymous

    Yes I tried to increase the page margins to 280px, but just the footer moves upwards…
    It has no impact on the content.

    #5739

    Hillel Coren
    Keymaster

    I did some quick testing, you may also need to increase y1 and y2 values on the footer tab to move the footer down.

    #5740

    Anonymous

    Hmm I’m not quite sure where to place the y1 and y2 values.
    No changes when I place the values like this.

    {
    “columns”: [
    {
    “text”: “$invoiceFooter”,
    “alignment”: “center”,
    “y1”: “100”,
    “y2”: “100”,
    }
    ],
    “layout”: [
    {
    “y1”: 100,
    “y2”: 200
    }
    ],
    “margin”: [
    40,
    100,
    40,
    0
    ]
    }

    #5741

    Hillel Coren
    Keymaster

    Have you customized the footer, the default bold design has a ‘line’ section. There should be a margin setting for the $invoiceFooter text.


    [
    {
    "canvas": [
    {
    "type": "line",
    "x1": 0,
    "y1": 0,
    "x2": 600,
    "y2": 0,
    "lineWidth": 100,
    "lineColor": "$secondaryColor:#292526"
    }
    ]
    },
    {
    "columns": [
    {
    "text": "$invoiceFooter",
    "margin": [
    40,
    -40,
    40,
    0
    ],
    "alignment": "left",
    "color": "#FFFFFF"
    }
    ]
    }
    ]

    #5743

    Anonymous

    Hi Hillel

    Thank you very much. I could solve the problem now!
    I used the standard template and customized it again. Now it works.

    Thank you so much for your help and the great software 🙂

    #5744

    Hillel Coren
    Keymaster

    Great to hear, thanks for letting us know!

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Posted in: