Home Forums Support Transfer White Label License

This topic contains 20 replies, has 2 voices, and was last updated by  Hillel Coren 1 day, 6 hours ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #24683

    jtomelevage
    Participant

    Hello,

    I just purchased the White Label license and want to know if I need to do anything to transfer it.

    We are moving our Invoice Ninja installation from subdomain.domain-A.com to subdomain.domain-B.com.

    Do I just install the license key, or is there anything else I need to do?

    Thanks,
    John

    #24684

    Hillel Coren
    Keymaster

    If you move the app database using the mysqldump then the license will be transferred with it.

    #24685

    jtomelevage
    Participant

    We have already moved everything via JSON export / import.

    Will adding the license key to the new installation break anything?

    #24686

    Hillel Coren
    Keymaster

    If you email us at [email protected] we can send you your license key.

    The JSON transfer is designed for people switching to/from the hosted version, if you can use mysqldump it’s much better.

    #24687

    jtomelevage
    Participant

    I still have the email with my license key, unless it has changed.

    Will moving the installation break our Stripe installation/setup?

    Will Stripe transactions fail coming from the new URL?

    #24688

    Hillel Coren
    Keymaster

    Great, then you should be able to reapply the license manually

    If the domain has changed and you’re using Stripe webhooks you’ll need to update the endpoint

    #24689

    jtomelevage
    Participant

    We are not using Stripe web hooks. No endpoints have been setup.

    #24690

    jtomelevage
    Participant

    One last question: When we did the JSON export / import it looks like the client activity did not import. Would this have been done if we did the database dump and import?

    #24693

    Hillel Coren
    Keymaster

    Yes, using mysqldump includes all data/the JSON transfer does not

    #24707

    jtomelevage
    Participant

    I did the database (MySQL) dump from the old location and imported it into the new location and we see several issues:

    – The company logos were absent (not really critical, we can re-install them)
    – We see “Whoops, looks like something went wrong when clicking on a client name in the clients tab.

    #24730

    jtomelevage
    Participant

    Bump

    #24763

    Hillel Coren
    Keymaster

    Are there any details about the error in storage/logs/laravel-error.log

    #24764

    jtomelevage
    Participant

    I found a bunch of these. I have changed the IP address to nnn.nnn.nnn.nnn and the domain name to domain_name and the user info to first_name last_name:

    [2020-05-18 18:52:34] production.ERROR: ***Illuminate\Contracts\Encryption\DecryptException*** [0] : /var/www/vhosts/domain_name.com/account.domain_name.com/vendor/laravel/framework/src/Illuminate/Encryption/Encrypter.php [Line 195] => The MAC is invalid. {"context":"PHP","user_id":2,"account_id":2,"user_name":"first_name last_name","method":"GET","user_agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1 Safari/605.1.15","locale":"en","ip":"nnn.nnn.nnn.nnn","count":4,"is_console":"no","is_api":"no","db_server":"mysql","url":"clients/3"} []

    #24765

    Hillel Coren
    Keymaster

    Did you copy over the original .env file? This error can occur if the value of APP_KEY is changed.

    #24766

    jtomelevage
    Participant

    No, I did not copy over the original .env file. I did not see that mentioned to do. I will try it again and copy the .env file.

    #24767

    jtomelevage
    Participant

    Cool, that eliminated the Whoops, looks like something went wrong” error message but there is another issue: When I click on a client and then “View in Portal” I am re-directed to the old domain.

    EDIT: I just reviewed the .env file and there is a line:

    APP_URL=https://billing.domain_name.com

    Could this be the issue?

    • This reply was modified 1 day, 7 hours ago by  jtomelevage.
    #24769

    Hillel Coren
    Keymaster

    Yes, it needs to be updated

    #24770

    jtomelevage
    Participant

    Excellent! I have changed it and so far I cannot see any errors. Is there anything else you would recommend I look for, or change?

    #24771

    Hillel Coren
    Keymaster

    Not unless you see any problems…

    #24772

    jtomelevage
    Participant

    So far so good.

    I want to thank you for helping me out with this. I was hoping I could begin using the new domain for June and now it looks like I can.

    Thanks again!

    #24773

    Hillel Coren
    Keymaster

    Happy to help, glad it’s working!

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.

Posted in: