Home Forums Support Whoops, looks like something went wrong.

This topic contains 4 replies, has 2 voices, and was last updated by  Geno 2 weeks, 5 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #24647

    Geno
    Participant

    Hey guys, hope you will help me, I really want to use Invoice Ninja on my server.

    I’m trying to install from Softaculous, it tells me the install was ok. And when i’m going to the url it says : Whoops, looks like something went wrong.

    At first I was on PHP version 7.4, so I downgraded to 7.3 and tried to reinstall from scratch but nothing change (except in the logs).

    I tried to find a solution here but i’m not sure.

    Here are the logs from laravel-error.log

    [2020-05-07 17:36:51] production.ERROR: ***Doctrine\DBAL\Driver\PDOException*** [0] : /home/safengks/crm.safemind.fr/ninja/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php [Line 47] => could not find driver {“context”:”PHP”,”user_id”:0,”account_id”:0,”user_name”:””,”method”:”GET”,”user_agent”:”Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.129 Safari/537.36″,”locale”:”en”,”ip”:”77.200.153.118″,”count”:1,”is_console”:”no”,”is_api”:”no”,”db_server”:”mysql”,”url”:”login”} []
    [2020-05-07 17:36:51] production.ERROR: ***Doctrine\DBAL\Driver\PDOException*** [0] : /home/safengks/crm.safemind.fr/ninja/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php [Line 47] => could not find driver {“context”:”PHP”,”user_id”:0,”account_id”:0,”user_name”:””,”method”:”GET”,”user_agent”:”Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.129 Safari/537.36″,”locale”:”en”,”ip”:”77.200.153.118″,”count”:2,”is_console”:”no”,”is_api”:”no”,”db_server”:”mysql”,”url”:”login”} []
    [2020-05-07 17:36:51] production.ERROR: ***Illuminate\Database\QueryException*** [0] : /home/safengks/crm.safemind.fr/ninja/vendor/laravel/framework/src/Illuminate/Database/Connection.php [Line 664] => could not find driver (SQL: select count(*) as aggregate from users where users.deleted_at is null) {“context”:”PHP”,”user_id”:0,”account_id”:0,”user_name”:””,”method”:”GET”,”user_agent”:”Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.129 Safari/537.36″,”locale”:”en”,”ip”:”77.200.153.118″,”count”:3,”is_console”:”no”,”is_api”:”no”,”db_server”:”mysql”,”url”:”login”} []

    Thanks for your attention 🙂

    #24652

    Hillel Coren
    Keymaster
    #24654

    Geno
    Participant

    Hello Hillen,

    Thank you ! It is exactly that. If I can help someone :

    If you have a Web server by a provider with cpanel, PDO Driver for MySQL is not activate by default.
    To activate it you have to go in Cpanel, search PHP Version –> in PHP Version you have a button with Switch to PHP Version and you will find nd_pdo_mysql wich is not checked.
    So tick it and go on your Ninja login and miracle, it works 😀 😀

    Thank you again Hillen

    #24655

    Hillel Coren
    Keymaster

    Awesome, glad to hear it!

    #24663

    Geno
    Participant

    Have a nice day 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Posted in: